Patch Cisco VPN Client and Kernel >= 2.6.19

Se usate il Cisco VPN Client e per esempio la nuovissima versione di sviluppo di Ubuntu (e quindi un kernel superiore o uguale al 2.6.19) avrete visto che il modulo cisco_ipsec non ne vuole sapere di ricompilarsi.

La soluzione a questo problema ce la da’ Alexander che ha scritto una patch per il Cisco VPN Client. Potete trovare tutto nel suo post “Cisco VPN Client and Linux Kernel 2.6.19“, bastera’ scaricarsi il diff file, copiarlo nella dir del vpn client e lanciare il comando:

patch -p1 < vpnclient-linux-2.6.19.diff

Io l’ho provata anche su un 2.6.20 e funziona p erfettamente. Grazie Alexander.

Post simili:

If you enjoyed this post, please consider to leave a comment or subscribe to the feed and get future articles delivered to your feed reader.

3 Responses to “Patch Cisco VPN Client and Kernel >= 2.6.19”
  1. Patch Cisco VPN Client and Linux Kernel 2.6.22
    12:09 on August 19th, 2007

    […] Ciao! E’ la prima volta che ti vedo qua, se vuoi seguirmi sottoscrivi il feed RSS.If you’re new here, you may want to subscribe to my RSS feed. Thanks for visiting!Ho scoperto oggi, aggiornando il mio portatile da Ubuntu Feisty Fawn 7.04 alla nuova versione in sviluppo e disponibile da Ottobre 2007 Ubuntu Gutsy Gibbon 7.10beta, che nel nuovo kernel 2.6.22 hanno ricambiato qualcosa in modo da non far funzionare di nuovo l’installazione del modulo per il CiscoVpn Client com’era successo con il kerne…. […]

  2. v1nNì€
    02:38 on May 14th, 2007

    avrei una piccola precisazione per chi stava impazzaendo per far compilare quell’ipsec di mxxda..basta inserire il file che si chiama IPSecDrvOC_linux.c come file da patchare..poi se non si connette rinominate il file patch con la versione del kernel in uso..ciao!

  3. Tommytnt
    12:15 on December 19th, 2006

    Io ai tempi avevo risolto con vpnc http://www.unix-ag.uni-kl.de/%7Emassar/vpnc/
    anche se la documentazione è quello che è…

Leave a comment

(required)

(required)


*

Categories